小程序界面设计_webpack3里使用uglifyjs压缩js时打包

2021-01-11 10:16

webpack3里使用uglifyjs压缩js时打包报错的解决       这篇文章主要介绍了webpack3里使用uglifyjs压缩js时打包报错的解决,小编觉得挺不错的,现在分享给大家,也给大家做个参考。一起跟随小编过来看看吧

执行打包命令后报错,重新浏览文档后发现该写法只适用于webpack4,而我的环境是webpack3.x,于是更换了uglifyjs的写法:

const UglifyJsPlugin = require('uglifyjs-webpack-plugin')
module.exports = {
 plugins: [
 new UglifyJsPlugin(),
}

再次执行打包命令仍然报错,猜想可能是最新版本的uglifyjs已经不支持该写法,于是:

npm view uglifyjs-webpack-plugin versions

重新安装低版本插件

cnpm install uglifyjs-webpack-.0 -D

打包成功!

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持凡科。




扫描二维码分享到微信

在线咨询
联系电话

020-66889888